CREATE AND EDIT SCREEN LAYOUTS Step-by-Step

 

Example Site Custom Application/Setup Window Layout in Progress

 

Introduction to SCREEN LAYOUTS

The following information details the processes involved in creating new Screen (application/window) Site Custom (user generated) layouts and editing existing ones. (Creating and editing reports via the REPORT EDITOR is covered in another Help topic.)

Site Custom layouts are user interfaces for almost every application and window in the system that you can create from scratch or duplicate from existing layouts, including the Xytech Standard and Xytech Custom layouts that come standard with MediaPulse. They can be modified to meet the needs of an individual user, a group of users, a particular division (if applicable), or all users. You can identify whether a layout is a Site Custom, Xytech Standard, or Xytech Custom layout by looking to the Layout Source Field in the LAYOUTS LIST WINDOW.

You can design a Site Custom layout to include as many or as few fields as are available and arrange these fields in any configuration that you wish, including grouping them into topic areas, radio button areas, and unique tab pages. Additionally, you may change the field prompts (label names) and drop-down list values as needed, control the tab stops, and create custom tool tips that appear when users hover over a field prompt if the layout has been selected for an application or window.

LAYOUT TYPES

There are two basic types of Screen window layouts in MediaPulse: an APPLICATION MAINTENANCE / SETUP WINDOW and a SEARCH LIST WINDOW. Search List Windows are the screens used to locate records for a given application and Application Maintenance / Setup Windows are the screens used to view, edit, and create individual records. There are some slight differences in how you establish these two layout types, so the steps below on creating new layouts are split into two sections. (Creating and editing reports via the REPORT EDITOR is covered in another Help topic.)

TIPS!

}  Like any new tool, mastering the LAYOUT APPLICATION and the LAYOUT TOOLS PANE – which are used in the creation and design of Site Custom layouts – takes some practice. It is recommended that you create several test layouts before designing or editing your first actual Site Custom layouts. Use the following steps to try duplicating a layout, creating tab pages, adding topic areas and radio button areas to the tabs, placing fields in the areas and organizing them, and modifying the fields’ prompts. Once you are comfortable performing all these layout techniques, creating and editing layouts will be fast and easy!

}  If you don’t want users to access the Xytech Standard layouts (or any other type of layout), uncheck the Active Field in the LAYOUT PROPERTIES WINDOW.

IMPORTANT!

Keep in mind that when you are creating layouts, design them so that they (and all their fields and columns) will display properly on the screen size of all the monitors of your users. If some users have large monitors or use multiple monitors, while other users will access MediaPulse on laptops or other smaller monitors, you may want to create different layouts that are optimal for those user groups.

When you resize windows at runtime (e.g., creating a record), blocks will get wider based on the widest block on a tab page / window (even if it is only widest by a fraction of an inch or even a pixel). If you reduce the width of a window, any space between blocks inside of other blocks will be maintained, even if you make a window too small so some of the fields are hidden from view. So, make sure that each block fills as much space within its parent block as possible.

 

DOCUMENTS AND LAYOUTS

There are two concepts that are important to understand before creating your own layouts:

Documents      A document is a collection of links to one or more tables from the MediaPulse database plus their associated fields/columns, prompts, business rules, and data. A document may be associated with one or more screen and/or report layouts. Generally, users interact with a document and the data in its tables through a layout.

Layouts             A layout allows users to interface with a particular document. Both screen and report layouts may be created and modified via the LAYOUT APPLICATION to present as many or as few fields/columns (and their associated business rules) from the document as desired. Layouts can only be constructed based on the attributes available in their underlying documents or by those supported document customizations, and using the formatting capabilities available within the Layout Application.

 

CREATE A NEW APPLICATION/SETUP WINDOW LAYOUT Step-by-Step

 

The following steps detail how to create a new layout based on a particular document and establish various tab pages, areas, and fields in the Layout Window.

LAYOUT DUPLICATION PROCESS

The right mouse button menu command Duplicate Row(s) in the LAYOUTS LIST WINDOW allows you to make an exact copy of a selected layout, keeping all of the tab pages, areas, and fields in place. When you duplicate a layout in this manner, the LAYOUT PROPERTIES WINDOW will open so that you can modify the description or any other settings and then opens the Layout Application so you can modify the layout.

This process may prove to be helpful if you want to create a new layout that is very similar to the layout you are duplicating, such as, a duplicate Site Custom layout that needs minor changes from the source Site Custom layout. If you choose to use this feature, follow the steps outlined at the bottom of this document for editing an existing layout.

However, if you are creating a new layout for a particular document or need to make more than minor changes to a layout, it is recommended to go through the steps outlined below. It is a bit easier and faster to start from scratch than to move and delete many existing fields and areas.

 

1.     In the Modules pane, select the Layout option from the System menu’s New submenu to access the Document Customizations List Window.

You can also access this window by clicking the Plus icon  or selecting the New Layout option from the Actions Button of the LAYOUTS LIST WINDOW.

NOTE

The Document Customizations List Window that opens does not allow you to access the Document Customization Maintenance Window for a document. It is only used to help you find a particular document for which you can create a new layout. The Document Type Field of this window can help identify whether a document can be used to create maintenance application layouts (Document Type Field value of Maintenance), setup windows (Document Type Field value of Setup), or search list windows (Document Type Field value of Select).

 

2.     Locate and select the Application/Setup Window document that you want to base your new layout upon and click the hyperlink in the ID Field. The LAYOUT PROPERTIES WINDOW will open.

You must first select an existing document to identify the source from which you will build your new layout. For example, if you want to make a layout for the Media Asset Maintenance Application document, you would select the row that shows Media Asset in the Document Description Field of the Document Customizations Window and Maintenance in the Document Type Field.

NOTE

To identify which layout is an Application or Setup Window versus a Search List Window, look to the Document Type Field. Application Windows are listed as Maintenance, Setup Windows are listed as Setup, and Search List Windows are listed as Select.

TIP!

To help find the layout that you wish to duplicate, use the Filter row to reduce the number of layouts in the Document Customizations Window. Entering a few letters (and/or numbers) in the filter row of the Document Description Column prompts the system to only show those layouts that begin with the letters you type. If you put a percentage symbol (%) before the letters you type, the system will show layouts that have those letters anywhere in the name. (The Document Description Column equates to the Layout Desc column in the LAYOUTS LIST WINDOW.)

Filter Row Example

 

3.     Change the fields as needed in the LAYOUT PROPERTIES WINDOW and then click the OK Button. The LAYOUT APPLICATION will open as a blank window.

The Layout Properties Window allows you to establish settings for the layout, such as, the name of the layout and which users may use the layout when accessing its associated application or window. Refer to the LAYOUT PROPERTIES WINDOW topic for details on each field.

New Application/Setup Window Layout Example

TIP!

Before moving on, it is recommended that you familiarize yourself with the working environment of the LAYOUT APPLICATION and its LAYOUT TOOLS PANE. The fields, buttons, icons, etc. that you will encounter are covered in detail in the linked topics.

 

4.     Use the Field Block  or List Block Icons  from the LAYOUT TOOLS PANE to define the initial screen (tab page).

These icons are used to create the tab pages, topic areas, and radio button areas into which you will eventually place the fields. When you drag one of these icons to the layout, the system opens a simple version of the Layout Properties Window that allows you to define the prompt (label name) that will appear in the resulting tab page’s “flap” (e.g., )  or the header section of a topic area or radio button area.

Layout Properties Window Example

Click the OK Button to complete the process.

 

5.     (Optional) Use the Field Block , List Block , or Note Block Icons  from the LAYOUT TOOLS PANE to define an additional tab page.

If you’d like to have an additional tab page in the current layout, drag and drop an icon to the right of the existing tab’s “flap” (e.g., ) and complete the Layout Properties Window as before. A blank tab page will appear directly next to the existing tab. You can reorganize tabs at any time by simply dragging and dropping them into the desired position.

If you only need one tab page, the layout will appear without a flap when assigned to an application or window.

NOTE BLOCK TAB PAGES

You may only add note fields to Note Block tab pages. Doing so prompts the system to change the tab into a rich-text typing area for notes. If you add additional note fields to a Notes Tab Page, those notes will be accessible as tabs at the bottom of the window. Refer to the Work Order Application’s NOTES TAB PAGE topic for an example and specific details of how the tab functions.

LAYOUT NOTE

In addition to placing a tab next to an existing tab in the same window, you also have the ability to have additional tab pages below an existing tab (Stacked Tabs) and off to the right of an existing tab (Right Adjacent Tabs). This allows you to have a layout that displays multiple tab pages on the screen at the same time. Just drag an icon and drop it somewhere inside the working area but not within an existing tab or directly to the right of a tab’s flap.

 Stacked Tabs Example

 

 Right Adjacent Tabs Example

 

6.     Use the Field Block , List Block , or Note Block Icons  from the LAYOUT TOOLS PANE to define a topic area in the initial tab page.

Drag and drop an icon inside the tab and complete the Layout Properties Window as before.

IMPORTANT!

}  You must place ALL fields on any given Field Block tab page within the boundaries of either topic or radio button areas. Fields must not be placed directly onto a tab page or the layout may possibly function incorrectly. Create topic and/or radio button areas and then place the desired fields within them.

}  Unlike with Field Block tab pages, you do not need to add areas to List Block and Note Block tab pages before placing fields on them. Of course, you can add areas if you want them. Adding fields to a List Block and Note Block tab page is identical to adding fields to a List Block or Note Block topic or radio button area. Refer to the steps below for details.

RESIZE NOTES

}  You can resize any tab page as well as any area by moving the cursor to the right edge, bottom edge, or lower right corner. The cursor will turn into a double-sided arrow that points in the direction that you can drag an edge: to the right or left to make the area or tab wider or more narrow, up or down to make it taller or shorter, or at an angle, which allows you to resize both edges at the same time.

When you see the desired arrow, use the left-click button on your mouse and drag the cursor to resize the tab or area.

 Resize Example

}  Make sure that each block fills as much space within its parent block as possible. If you leave space between blocks, that space is “absolute.” This means that if you resize a layout at runtime, that space between blocks will be maintained, even if you make a window too small so some of the fields are hidden from view.

 

7.     (Optional) Use the Field Block , List Block , or Note Block Icons  from the LAYOUT TOOLS PANE to add other topic areas to the right or below the existing one.

Drag and drop an icon directly to the right of the existing topic area (Right Adjacent) or directly below it (Stacked) and complete the Layout Properties Window as before.

  Stacked and Right Adjacent Topic Areas Example

LAYOUT NOTE

Make sure that each block fills as much space within its parent block as possible. If you leave space between blocks, that space is “absolute.” This means that if you resize a layout at runtime, that space between blocks will be maintained, even if you make a window too small so some of the fields are hidden from view.

 

8.     (Optional) Use the Field Block , List Block , or Note Block Icons  from the LAYOUT TOOLS PANE to add a second topic area within the existing one.

Drag and drop an icon directly inside the existing topic area (Nested Area) and complete the Layout Properties Window as before.

  Nested Topic Area Example

LAYOUT NOTE

Make sure that each block fills as much space within its parent block as possible. If you leave space between blocks, that space is “absolute.” This means that if you resize a layout at runtime, that space between blocks will be maintained, even if you make a window too small so some of the fields are hidden from view.

 

9.     (Optional) Use the Field Block , List Block , or Note Block Icons  from the LAYOUT TOOLS PANE to change a topic area into a radio button area.

Before you create a radio button area, you must create another topic area first. Drag and drop an icon somewhere within the boundaries of the tab page or within a topic area and complete the Layout Properties Window as before.

Move your mouse so that it is over the header section of the newly created topic area. Use the left-click button and drag it into the header section of the existing topic area. When you use the left-click button, the cursor will change to show a box below it , indicating the topic area can be moved. When you release the left-click button, the system will change both areas to radio button areas.

  Example of Dragging One Header Section to the Header Section of another Topic Area

 

  Radio Button Areas Example

LAYOUT NOTES

}  You can rearrange the order in which the radio buttons appear by simply clicking one and moving it to the position of another radio button. In the above example, if you wanted the Job Billing radio button to appear first, you would click, drag, and drop it on top of the Job radio button.

}  In the same way that you created a radio button area from a topic area, you can turn the radio button area back into a topic area by clicking and dragging the radio button to another area within the tab page. Additionally, you can turn it (and any other area) into a tab page (linked to the current tab as a flap, a Right Adjacent tab, or a Stacked tab) by dragging it outside the boundaries of its current tab page.

}  Make sure that each block fills as much space within its parent block as possible. If you leave space between blocks, that space is “absolute.” This means that if you resize a layout at runtime, that space between blocks will be maintained, even if you make a window too small so some of the fields are hidden from view.

 

10.  Add fields from the LAYOUT TOOLS PANE to a topic area or radio button area.

Find the fields you want to add by clicking the Plus icon  to the left of a given database table or subtable in the Layout Tools pane. The fields that belong to the selected table will be visible and you will be able to click and drag them into the topic or radio button area.

IMPORTANT!

}  You may only add fields from one table to a given topic or radio button area. If you want fields from multiple tables to appear on the same tab page, you must create additional areas and place the fields in them.

}  Certain groups of Actions Button commands will be invisible when users access a layout’s record unless fields from particular tables have been added to the layout. For example, the ORDER TRANSACTIONS WINDOW document includes order, job, media asset, etc. tables. Unless fields from those tables have been added to a layout, their associated Actions Button commands will not be displayed (nor will custom buttons show).

 

The block icon you chose to create a given area determines how the area displays the added fields. Following are the three area possible types:

1.     Field Block

Field Block Area Example

Field Block areas allow you to organize fields in any way that you want. Dragging and dropping a field from the Layout Tools pane into an area prompts the system to place it exactly where you unclicked the mouse. You can move this field anywhere within the area. When you hover the cursor over a field, a Hand Icon  will appear indicating that you can click and drag the field to a new location.

Hand Icon Example

You can also resize each field, making them as wide or narrow as needed. When you place the cursor at the edge of a field, a Resize Arrow will appear. Use the left-click button on your mouse and drag the arrow to resize the field.

Refer to step 10 for details about organizing fields in a List Block area.

 

2.     List Block

List Block Area Example

List Block areas organize the fields you add into columns. When you add the first field to the area, it changes to a list view. Each additional field you add will be placed at the end of the row of columns. If you want to change the display order of the columns, click on one and move it to the right or left until it is in the spot you want.

You can also resize each column, making them as wide or narrow as needed. When you place the cursor at the edge of a column, a Resize Arrow will appear. Use the left-click button on your mouse and drag the arrow to resize the column.

NOTE

If you add a Note Field to the List Block area, you need to activate the drop-down/pop-up notes feature. (Any field with the word “Note” in its factory prompt is a Note Field.) Right click on the Note Field and in the Control Type option’s drop-down list, scroll to the bottom of the list and select Drop-Down Multi Line.

TIP!

Use the LIST BLOCK AREA – FIELD right mouse button menu options to control default filtering, sorting, grouping, and other display features for each column (field). Access the menu by right-clicking any field in the List Block area. (The Filter Row displays by default, but you can change it as needed.)

 

3.     Note Block

Note Block Area Example

You may only add Note Fields to Note Block areas. (Any field with the word “Note” in its factory prompt is a Note Field.) Doing so prompts the system to change the block into a rich-text typing area for notes. If you add additional note fields to a Note Block, those notes will be accessible as tabs at the bottom of the area. 

 

11.  Organize and set the properties on fields in a Field Block topic area or radio button area.

There are a variety of options available to help you organize and establish properties on fields in a Field Block Area. In addition to basic left-click moving and resizing as detailed in the previous step, there is a Multi-field Tool that is available from the FIELD BLOCK AREA right mouse button menu.

This tool allows you to automatically align fields to the left or to the top, set fields to the same width, and establish the tab order of fields. Refer to the FIELD BLOCK AREA right mouse button menu topic for additional details.

Additionally, the right mouse button menu that is available on each FIELD in a Field Block Area allows you to control a variety of features about the fields including the tab order, whether a field prompt is visible, the font size of a field prompt, and the height of a field. You can also delete a field using a command from the menu. Refer to the FIELD BLOCK AREA – FIELD right mouse button menu topic for additional details.

 

12.  (Optional) Convert Actions Button commands into buttons.

You can make select Actions Button commands appear as buttons by default on a layout for all users who access the layout much in the same way that users can create custom buttons on the fly per window (i.e., selecting the Customize Buttons command from the Actions Button). Refer to the BUTTON CUSTOMIZATION STEP-BY-STEP topic for details on how to customize buttons.

Creating Custom Actions Buttons Example

IMPORTANT!

All possible Actions Button commands for the selected document are available in the Customize Menu Window. This includes commands that will not display when users access the layout as a program window based on established business rules and data restriction. Buttons made from commands that do not display in the Actions Button menu will also not display.

Commands may not display in the Actions Button menu (nor as custom buttons) for several reasons.

One such reason applies to commands that are invisible until a record has met certain requirements as defined by the business rules. For example, the Recalculate W/O command in the BID MAINTENANCE APPLICATION'S ACTIONS BUTTON MENU only appears on approved bid records. Similarly, the Unapprove Bid command will only show on approved bids. If either of these commands are added as custom buttons to the layout, when users create a new bid, these custom buttons will be invisible until the new bid is approved.

Another reason applies to commands that are invisible unless fields from a particular table have been added to a layout. For example, the ORDER TRANSACTIONS WINDOW document includes order, job, media asset, etc. tables. Unless fields from those tables have been added to a layout, their associated Actions Button commands will not be displayed nor will custom buttons show.

 

13.  (Optional) Modify the field prompts (label names) in the DOCUMENT PROMPTS WINDOW.

Open the Document Prompts Window by clicking the Prompts hyperlink at the bottom of the LAYOUT APPLICATION. (You can also access this window by selecting the Prompts option from the Actions Button of the LAYOUTS LIST WINDOW.) Make your changes in the Current Prompts column and click the Save & Close Button when complete.

This step allows you to change the field prompts that users see when applying the current layout to its associated application or window. This is necessary in situations where text must match certain business practices or lingo or when your users speak a language other than English. Refer to the DOCUMENT PROMPTS WINDOW topic for additional details.

IMPORTANT!

If you change the field prompts for any given layout, those same prompts will be changed for every other layout created from the same document. Prompts are managed at the document level, so any layout that has been created from a document will reflect the same field prompt values regardless of how the prompts were changed.

NOTE

If you want to change the layout’s language or edit existing non-English text, you must change only those line items that have the desired language code in the Language column (e.g., “es” for Spanish). The Document Prompts Window lists all field label prompts, regardless of region or language.

 

Tips on Using the Document Prompts Window

}  To reduce the number of rows that display in the window, use the Filter row at the top of the window. For example, to filter the display by language, enter the desired language code (e.g., es) into the Language column’s Filter Field. (The Auto Filter Row command in the right mouse button menu available from the window’s header row controls whether the Filter row displays.)

}  You can resize, sort, and move any column in this window (and all other list windows). This may make it easier to find and edit the values in the columns. You can also save any column adjustments via the Save Layout Changes command available from the Layout Settings Button .

 

14.  (Optional) Modify certain hard-coded drop-down list field values in the DOCUMENT PROMPTS WINDOW.

Open the Document Prompts Window by clicking the Prompts hyperlink at the bottom of the LAYOUT APPLICATION. (You can also access this window by selecting the Prompts option from the Actions Button of the LAYOUTS LIST WINDOW.) Make your changes to the hard-coded drop-down list values in the Current Named Values column. Change the words that follow the code; for example, when editing the “G=Global” value for the Access Field’s drop-down list, only change the word “Global” that appears after the “G=.” Click the Save & Close Button when complete.

This step allows you to change the drop-down list field values that have specific system functionality and are not controlled by Setup menu windows. This is necessary in situations where text must match certain business practices or lingo and also when your users speak a language other than English. Refer to the DOCUMENT PROMPTS WINDOW topic for additional details.

IMPORTANT!

}  When changing the drop-down list values, it is important not to change the code preceding the word that you want to modify or translate. These codes are used by the system to perform specific functions.

}  If you change the drop-down list values for any given layout, those same values will be changed for every other layout created from the same document. Drop-down list values are managed at the document level, so any layout that has been created from a document will reflect the same values regardless of how they were changed.

NOTE

If you want to change the layout’s language or edit existing non-English text, you must change only those line items that have the desired language code in the Language column (e.g., “es” for Spanish). The Document Prompts Window lists all applicable drop-down list values, regardless of region or language.

 

15.  (Optional) Modify or add field-level tool tips in the DOCUMENT PROMPTS WINDOW.

Open the Document Prompts Window by clicking the Prompts hyperlink at the bottom of the LAYOUT APPLICATION. (You can also access this window by selecting the Prompts option from the Actions Button of the LAYOUTS LIST WINDOW.) Make your changes or add tips in the Current Tool Tips column; click the Save & Close Button when complete.

This step allows you to change the field-level tool tips that users see when they hover over a particular field prompt. This can be helpful for users to remind them what certain fields are used for. Refer to the DOCUMENT PROMPTS WINDOW topic for additional details.

IMPORTANT!

If you change the field-level tooltips for any given layout, those same tooltips will be changed for every other layout created from the same document. Tooltips are managed at the document level, so any layout that has been created from a document will reflect the same tooltip values regardless of how the tooltips were changed.

NOTE

If you want to change the layout’s language or edit existing non-English text, you must change only those line items that have the desired language code in the Language column (e.g., “es” for Spanish). The Document Prompts Window lists all tool tips, regardless of region or language.

 

16.  When you have completed your new Application/Setup Window layout, click the Save & Close Button of the Layout Application.

NOTE

During the Save process, the system will issue a message that will allow you to reset any user-level customizations made to the current layout (e.g., custom window sizes, custom buttons, custom column positions in list blocks) so that users will see the changes you made during the current session. If you do not reset these customizations, users may not see the changes you made to the layout.

}  Selecting the Yes Button prompts the system to run the same process as the RESTORE ORIGINAL LAYOUT command available from the Actions Button for all users.

}  Selecting the No Button will still save your changes to the layout, but users will only see your changes if they do not have custom settings for the layout or if they manually run the RESTORE ORIGINAL LAYOUT command.

TIP!

As with many tools that allow you to create and edit content, it is a good idea to save your work as you go. Click the Save & Close Button periodically (e.g., every 15 to 30 minutes) to ensure that you don’t lose your layout designs if something goes wrong. You can access your new layout from the LAYOUTS LIST WINDOW. Refer to the Edit an Existing User Layout section below for details on locating your layouts.

 

 

CREATE A NEW SEARCH LIST WINDOW LAYOUT Step-by-Step

 

Many of the steps of creating a new Search List Window layout are the same as creating an Application/Setup Window layout, so the steps below will detail the unique aspects of the process.

NOTE

To identify which layout is an Application/Setup Window versus a Search List Window, look to the Class Name Field in the LAYOUTS LIST WINDOW of the layout you wish to duplicate. If the value ends in the letters “List,” it is a Search List Window.

 

1.     Create a new layout as detailed in steps 1 through 3 above, but make sure to choose a Search List Window document (Document Type Field value of Select) in the special version of the Document Customizations Window (as detailed above). The LAYOUT APPLICATION will open as a blank window.

NOTE

The window will be divided into two tab pages: Data and Criteria.

}  The Data Tab Page allows you to create the search list window that appears when users access the layout from the Modules pane. You will use a List Block area to create this layout, but you may also create radio button areas comprised of different List Block areas if needed.

}  The Criteria Tab Page allows you to create the Criteria Window layout, which is accessed by users when the click the Advanced Search hyperlink in the upper-right corner of a search list window. You will use a Field Block area to create this layout, but you may also create radio button areas comprised of different Field Block areas if needed.

 

Search List Window Layout Example

 

2.     Add a List Block to the Data Tab Page and add fields from the LAYOUT TOOLS PANE.

Refer to step 6 above for adding a List Block to the tab page and step 10 above for adding fields to the area.

LAYOUT NOTE

There will (generally) be two database table options in the Layout Tools pane: one labeled Criteria, which is used to add fields to the Criteria Tab Page, and one that reflects the name of the search list window (e.g., Work Orders for the above screenshot). The second option must be used to add fields to the Data Tab Page.

 

3.     (Optional) Add a Field Block to the Criteria Tab Page and another to create a topic area. Add fields from the LAYOUT TOOLS PANE.

Refer to steps 6 and 7 above for adding a Field Block and a topic area to the tab page and steps 10 and 11 for adding fields to the area.

LAYOUT NOTE

There will (generally) be two database table options in the Layout Tools pane: one labeled Criteria, which is used to add fields to the Criteria Tab Page, and one that reflects the name of the search list window (e.g., Work Orders for the above screenshot). The first option must be used to add fields to the Criteria Tab Page.

 

4.     (Optional) Set custom column filters, sorting options, Actions Button command buttons, default search values, etc.

}  Refer to the LIST BLOCK AREA – FIELD right mouse button menu topic for details on sorting, filtering, and grouping columns.

}  Step 12 above details you to turn Actions Button commands into buttons by default. Refer to the BUTTON CUSTOMIZATION STEP-BY-STEP topic for details on how to customize buttons.

}  Refer to the Layout Mode command available from the LIST BLOCK AREA right mouse button menu topic for details on establishing default search values for the current Search List Window.

 

5.     When you have completed your new Search List Window layout, click the Save & Close Button of the Layout Application.

Use any of the layout tools and tips from the Application/Setup section to complete the Search List Window layout.

NOTE

During the Save process, the system will issue a message that will allow you to reset any user-level customizations made to the current layout (e.g., custom window sizes, custom buttons, custom column positions in list blocks) so that users will see the changes you made during the current session. If you do not reset these customizations, users may not see the changes you made to the layout.

}  Selecting the Yes Button prompts the system to run the same process as the RESTORE ORIGINAL LAYOUT command available from the Layout Settings Button for all users.

}  Selecting the No Button will still save your changes to the layout, but users will only see your changes if they do not have custom settings for the layout or if they manually run the RESTORE ORIGINAL LAYOUT command.

TIP!

As with many tools that allow you to create and edit content, it is a good idea to save your work as you go. Click the Save & Close Button periodically (e.g., every 15 to 30 minutes) to ensure that you don’t lose your layout designs if something goes wrong. You can access your new layout from the LAYOUTS LIST WINDOW. Refer to the Edit an Existing User Layout section for locating your layouts.

 

 

EDIT AN EXISTING LAYOUT Step-by-Step

 

Many of the steps of editing an existing layout are similar to or the same as creating a layout, so the steps below will detail the unique aspects of the process.

 

1.     Select the Layout option from the System menu in the Modules pane to access the LAYOUTS LIST WINDOW.

This window lists all layouts that exist for the system: Xytech Standard, Xytech Custom, and Site Custom; Screen (application/window) and Report. You may only edit those layouts that have a Layout Source Field value of User. (Creating and editing reports is covered in another Help topic.)

TIP!

To help find the layout that you wish to edit, use the filter row to reduce the number of layouts in the Layouts List Window. Entering a few letters and/or numbers in the Filter row of the window’s columns prompts the system to only show those layouts that begin with the letters and/or numbers you type. If you put a percentage symbol (%) before your entry, the system will show layouts that have those letters anywhere in the name. (See the screenshot below for an example.)

Since you can only edit Site Custom layouts, enter Site Custom into the Layout Source Filter row. Also, since this topic only covers creating and editing Screen layouts and not Report layouts, enter Screen in the Layout Type Filter row. If you’d like to reduce the number of layouts further and you know the name of the layout you wish to edit, enter the name (partial or complete) in the Layout Desc Filter row.

Filter Row Example

 

2.     Locate the layout that you want to edit and click the hyperlink in the Layout No Field to open the LAYOUT APPLICATION.

 

3.     Edit the layout as desired.

Use the techniques described in steps 4 through 14 of the Create a New Application/Setup Window Layout section above and the following resources to add, delete, and move fields, areas, and tab pages:

}  LAYOUT TOOLS PANE

}  DOCUMENT PROMPTS WINDOW

}  LAYOUT PROPERTIES WINDOW

}  FIELD BLOCK AREA right mouse button menu

}  FIELD BLOCK AREA – FIELD right mouse button menu

}  LIST BLOCK AREA right mouse button menu

 

4.     When you have completed editing the layout, click the Save & Close Button of the Layout Application.

NOTE

During the Save process, the system will issue a message that will allow you to reset any user-level customizations made to the current layout (e.g., custom window sizes, custom buttons, custom column positions in list blocks) so that users will see the changes you made during the current session. If you do not reset these customizations, users may not see the changes you made to the layout.

}  Selecting the Yes Button prompts the system to run the same process as the RESTORE ORIGINAL LAYOUT command available from the Actions Button for all users.

}  Selecting the No Button will still save your changes to the layout, but users will only see your changes if they do not have custom settings for the layout or if they manually run the RESTORE ORIGINAL LAYOUT command.

TIP!

As with many tools that allow you to create and edit content, it is a good idea to save your work as you go. Click the Save & Close Button periodically (e.g., every 15 to 30 minutes) to ensure that you don’t lose your layout designs if something goes wrong. You can access your new layout from the LAYOUTS LIST WINDOW. Refer to the Edit an Existing User Layout section for locating your layouts.